[ШАБЛОН] Выгрузка / Загрузка данных из Excel

Публикация № 1729305 19.09.22

Пользовательские инструменты - Загрузка и выгрузка в Excel

Excel Обработка Выгрузка Загрузка Выгрузка/Загрузка Файл Файлы Данные данные ЗагрузитьExcel ЗагрузкаИксель Иксель1С Иксель Эксель

Шаблон обработки по выгрузке / загрузке данных из Excel. Обработка может быть полезна как матерым программистам, так и новичкам. Первые не будут писать код заново, а вторые получают шаблон, с которым можно начинать разбираться с выгрузкой и загрузкой из Excel. Основная задача данного шаблона - сократить время на поиск и написание кода по выгрузке / загрузке данных.

Обработка запускается как внешняя из пользовательского режима. Выбирается путь к файлу Excel (*.xlsx;*.xls;) и происходит загрузка данных из файла по этому пути. Как таковой загрузки никаких данных тут не происходит, и обработка строк условная. Также, для упрощения, чаще всего Выбор файла и Выгрузку/Загрузку данных выполняю в одной процедуре, тут разбил для наглядности. 

Все тесты производились на платформе 8.3.20.1914, однако код отработает на любой из 8.2, 8.3.

 

Команда выбора файла на клиенте


&НаКлиенте
Процедура ПутьКФайлуНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	
	Режим = РежимДиалогаВыбораФайла.Открытие;
	ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
	ДиалогОткрытияФайла.ПолноеИмяФайла = "";
	Фильтр = "(*.xlsx;*.xls;)|*.xlsx;*.xls;|" + "(Все файлы)|*.*";		
	
	ДиалогОткрытияФайла.Фильтр = Фильтр;
	ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
	ДиалогОткрытияФайла.Заголовок = "Выберите файл";
	
	ДополнительныеПараметры = Новый Структура("ДиалогОткрытияФайла", ДиалогОткрытияФайла);
	ОписаниеОповещения = Новый ОписаниеОповещения("ВыборФайлаЗавершение", ЭтаФорма, ДополнительныеПараметры);
	ДиалогОткрытияФайла.Показать(ОписаниеОповещения);  

КонецПроцедуры

&НаКлиенте
Процедура ВыборФайлаЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
	
	ДиалогОткрытияФайла = ДополнительныеПараметры.ДиалогОткрытияФайла;	
	
	Если (ВыбранныеФайлы <> Неопределено) тогда
		ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
	КонецЕсли;

КонецПроцедуры


 

Команда загрузки данных из Excel

&НаКлиенте
Процедура ВыполнитьЗагрузку(Команда)    
	
	Если НЕ ЗначениеЗаполнено(ПутьКФайлу) Тогда
		Сообщить("Файл не выбран!");
		Возврат;
	КонецЕсли;		
	
	Попытка
		Excel = Новый COMОбъект("Excel.Application");
		Excel.WorkBooks.Open(ПутьКФайлу);
		Состояние("Обработка файла Microsoft Excel...");
	Исключение
		Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
		Сообщить(ОписаниеОшибки());
		Возврат;
	КонецПопытки;

	// Получим количество строк и колонок
	// В разных версиях Excel получаются по-разному, поэтому сначала определим версию
	Версия = Лев(Excel.Version, Найти(Excel.Version, ".") - 1);
	Если Версия = "8" Тогда
		ФайлСтрок = Excel.Cells.CurrentRegion.Rows.Count;
		ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 13);
	Иначе
		ФайлСтрок = Excel.Cells(1,1).SpecialCells(11).Row;
		ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;
	КонецЕсли;
	
	МассивСтруктур = Новый Массив;
	Для j = 2 По ФайлСтрок цикл

		Состояние("Состояние загрузки", Цел(j*100/ФайлСтрок), "Пояснение", БиблиотекаКартинок.Загрузить);
			
		СтруктураПозиций = Новый Структура;
		СтруктураПозиций.Вставить("Номенклатура", СокрЛП(Excel.ActiveSheet.Cells(j, 1).Value));  
		СтруктураПозиций.Вставить("ШтрихКод", СокрЛП(Excel.ActiveSheet.Cells(j, 2).Value));
		СтруктураПозиций.Вставить("ЕдиницаИзмерения", СокрЛП(Excel.ActiveSheet.Cells(j, 3).Value));
		СтруктураПозиций.Вставить("Цена", СокрЛП(Excel.ActiveSheet.Cells(j, 4).Value));
		СтруктураПозиций.Вставить("Количество", СокрЛП(Excel.ActiveSheet.Cells(j, 5).Value));
		СтруктураПозиций.Вставить("Сумма", СокрЛП(Excel.ActiveSheet.Cells(j, 6).Value));
		
		МассивСтруктур.Добавить(СтруктураПозиций);

	КонецЦикла;	    	
	
	ВыполнитьЗагрузкуНаСервере(МассивСтруктур);
	
	Excel.workbooks.Close();
	Excel.Quit();
	
КонецПроцедуры

&НаСервере
Процедура ВыполнитьЗагрузкуНаСервере(МассивСтруктур)
	// Вставить содержимое обработчика.
КонецПроцедуры

Команда выгрузки данных в Excel

&НаКлиенте
Процедура ВыполнитьВыгрузку(Команда)
	
	Если НЕ ЗначениеЗаполнено(ПутьКФайлу) Тогда
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "Не выбран файл. Выберите файл и повторите попытку!";
		Сообщение.Сообщить();
		Возврат;	
	КонецЕсли;
	
	Попытка
		Excel = Новый COMОбъект("Excel.Application");
		Состояние("Обработка файла Microsoft Excel...");
	Исключение
		Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
		Сообщить(ОписаниеОшибки());
		Возврат;
	КонецПопытки;   
	
	НоваяКнига = Excel.WorkBooks.Add();
	Лист = НоваяКнига.WorkSheets(1);
	
	// Заполним наименования колонок
	Лист.Cells(1, 1).Value = "ФИО"; // Значение
	Лист.Cells(1, 1).Font.Bold = 1; // Ширный фрифт
	
	Лист.Cells(1, 2).Value = "Дата рождения"; 
	Лист.Cells(1, 2).Font.Bold = 1;     
	
	// Получим данные
	МассивСтруктур = ПолучитьДанныеФизЛиц();  
	КоличествоСтрок = МассивСтруктур.Количество() - 1; 
	
	// Заполним Эксель
	Для Строка = 0 По КоличествоСтрок Цикл
		Лист.Cells(Строка + 2, 1).Value = СокрЛП(МассивСтруктур[Строка].ФИО);	
		Лист.Cells(Строка + 2, 2).Value = СокрЛП(МассивСтруктур[Строка].ДатаРождения);			
	КонецЦикла;	
	
	Попытка
		НоваяКнига.SaveAs(ПутьКФайлу);	
	Исключение
	  	Сообщить(ОписаниеОшибки());
	КонецПопытки;
	
	Excel.Quit();
	
КонецПроцедуры

&НаСервере
Функция ПолучитьДанныеФизЛиц()

	МассивДанных = Новый Массив();
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ФизическиеЛица.ФИО КАК ФИО,
		|	ФизическиеЛица.ДатаРождения КАК ДатаРождения
		|ИЗ
		|	Справочник.ФизическиеЛица КАК ФизическиеЛица
		|ГДЕ
		|	НЕ ФизическиеЛица.ПометкаУдаления";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	Выборка = РезультатЗапроса.Выбрать();	
	Пока Выборка.Следующий() Цикл
		
		СтруктураДанных = Новый Структура;
		СтруктураДанных.Вставить("ФИО", Выборка.ФИО); 
		СтруктураДанных.Вставить("ДатаРождения", Выборка.ДатаРождения);
		
		МассивДанных.Добавить(СтруктураДанных);
		
	КонецЦикла;
	
	Возврат МассивДанных;
	
КонецФункции 


Данный шаблон выгрузки / загрузки данных из Excel был добавлен для ускорения поиска нужного кода и разработки.

Статья будет дорабатываться, т.к. возможностей при выгрузке в Excel и загрузке данных из Excel больше, чем представлено. 

Делал на платформе 8.3.20.1914. 


Скачать файлы

Наименование Файл Версия Размер
[ШАБЛОН] Выгрузка / Загрузка данных из Excel:

.epf 7,91Kb
6
.epf 0.0.2 7,91Kb 6 Скачать

Специальные предложения

Автор запретил комментарии

См. также

Отправка монитора целевых показателей деятельности пользователям

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Бесплатно (free) Бесплатно (free)

Внешняя обработка позволяет выполнять отправку Монитора целевых показателей каждому пользователю согласно его настройкам. Каждый пользователь может получить на почту свой монитор целевых показателей в формате pdf. Отправить монитор целевых показателей можно и по отдельно взятому пользователю, как пользователю, так и на выбранную почту.

13.01.2023    582    10    Neiron_1C    2    

[РАСШИРЕНИЕ] Смена стиля интерфейса. Как изменить стиль 1С из пользовательского режима. 15 вариантов оформления. Темы для 1С.

Работа с интерфейсом Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Изменение цвета стиля - актуальная задача при работе с большим количеством баз или если Вы стильный человек. Стилёвое оформление интерфейса легко настраивается из пользовательского режима и очень просто дорабатывается в конфигураторе.

23.12.2022    6307    329    Neiron_1C    47    

Управление правами доступа. Просмотр прав и групп доступа на объекты. Проверить роли и профили у пользователя.

Роли и права Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка позволяет увидеть, какие роли используются для объектов, и в какие профили и группы доступа включена выбранная роль. Тестировалась на КА 2.5.8.267, ДО 2.1.31.5, БП 3.0.110.24, ЗУП 3.1.22.86, Розница 2.3.9.42, должна работать на конфигурациях с БСП.

5 стартмани

24.10.2022    1837    73    Neiron_1C    4    

Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо

Обработка документов Загрузка и выгрузка в Excel Обработка справочников Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Это перепиленная вдоль и поперек версия всем известной обработки "Загрузка из табличного документа" с диска ИТС. Добавлена возможность грузить в документы, виды расчетов, регистры расчета.

9 стартмани

25.06.2014    19628    39    Дмитрий74Чел    9    

Используем регистр штрихкодов по максимуму

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Розничная и сетевая торговля (FMCG) Розничная и сетевая торговля (FMCG) Россия Россия Абонемент ($m) Абонемент ($m)

Внешняя обработка для 1С Розницы 2.0 любого релиза, с возможностью загрузки данных из файлов XLS и описание использования регистра штрихкодов для хранения сопоставления внешних идентификаторов с номенклатурой 1С. Проверялось на версии 1С Розницы 2.2.8.27, платформа 8.3.18.1483

1 стартмани

10.10.2022    2513    4    independ    1    

Счет на оплату покупателю с QR кодом для УТ 10.3. Генерация QR-кода в УТ 10.3 на примере внешней печатной формы "Счет на оплату" для печати из Заказа клиента

Печатные формы Оптовая торговля Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

В 1С:Управление торговлей 10.3 не предусмотрена возможность для генерации QR-кода, поэтому новая возможность для оплаты не представлена. Показываю алгоритм добавления QR-кода в УТ 10.3 в виде внешней печатной формы "Счет на оплату" для печати из Заказа клиента. Делалось и тестировалось на "Управление торговлей", редакция 10.3 (10.3.57.2) / Платформа 8.3.20.1914.

1 стартмани

07.10.2022    3355    77    Neiron_1C    14    

[ШАБЛОН] Внешняя печатная форма с отладкой

Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Шаблон внешней печатной формы с отладкой. Поможет быстро создавать печатные формы, необходимо лишь изменять ключевые параметры, макет и заполнение Табличного документа.

1 стартмани

20.09.2022    2106    10    Neiron_1C    0    

Поиск пользователей в базах через COM-Объект. Запросы в базы 1С через COM-Объект. Расширение и Обработка.

Поиск данных Инструменты администратора БД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение и обработка позволяют найти пользователя в базах, которые находятся на одном сервере. Что делать, если баз много, не открывать же все базы?)

2 стартмани

13.09.2022    1484    1    Neiron_1C    5    

5 способов загрузки из Excel в 1С

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Конфигурация, состоящая из внешнего источника данных и одной обработки. Обработка содержит 5 примеров, как можно загрузить данные в 1С из Excel.

1 стартмани

29.03.2021    72910    70    elephant_x    27    

Заготовка обработки (внешняя печатная форма) заполнения Excel документа из 1С Промо

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Умеет заполнять как отдельные ячейки, так и таблицы в рамках листов Excel. Удобно при разработке различных “дашбордов” (с графиками, диаграммами), отчетов финансистов (где много формул), заполнения форм документов организации. Эксель шаблон может сделать пользователь (с нужным ему оформлением, формулами и т.д.) и впоследствии самостоятельно этот шаблон менять. Программисту нужно только настроить выдачу данных для заполнения шаблона. Может подключаться как внешняя печатная форма (для обычных и управляемых форм).

2 стартмани

29.07.2020    11819    28    wonderboy    0    

Простой способ загрузить файл Excel на тонком клиенте.

Загрузка и выгрузка в Excel Универсальные функции Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Самый простой способ загрузить файл Excel на тонком клиенте - это скопировать лист Excel в "табличный документ" на форме обработки и обрабатывать уже поля "табличного документа".

1 стартмани

30.10.2019    16546    8    John_d    16    

Загрузка из Excel (без использования com-объектов, без установленного Excel)

Обработка документов Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка не использует com-объект для чтения из файла, не нужен установленный Excel.

1 стартмани

22.03.2019    35387    325    Смешной 1С    30    

Конфигурация "Обмен данными Excel"

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Что будет, если скрестить Конвертацию 2.0, Модуль загрузки преобразования в значения БД от конвертации 3.0 и Excel шаблоны? Правильно, получится отличная подсистема "Обмен данными Excel", которую можно встраивать в существующие конфигурации и получить универсальный механизм по загрузке данных из Excel и вводу начальных данных. Данная подсистема позволит заменить множество различных обработок по загрузкам из Excel. Хочу отметить, что все интеграции через веб сервисы 1С по загрузкам soap пакетов (документов xml) можно адаптировать и универсально загружать через данную подсистему, правда, это потребует двух доработок конфигурации, но это возможно, архитектурное решение и идея включены в подсистему "Обмен данными Excel" и хочу Вам сообщить, что уже реализованы и доступны в новом обновлении 1.1.1.1.

2 стартмани

05.03.2019    15966    31    Алексей777    20    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    81799    374    Tatitutu    50    

Шаблон загрузки из Excel штатными средствами платформы 8.3 (без com, ado, Excel Application) (обычные и управляемые формы)

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Шаблон для быстрой загрузки из Excel (форматы *.xls, *.xlsx) средствами платформы 8.3 с помощью табличного документа. Не нужно работать с MSExcel.Application, ADO. В платформе 8.3 у табличного документа развили метод Прочитать(), и сейчас можно загружать данные не только из файлов *.mxl, но и *.xls и *.xlsx. Подробнее в описании.

1 стартмани

07.12.2018    25580    113    DarkPinch222    4    

Инструменты бухгалтера: Загрузка из Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Абонемент ($m) Абонемент ($m)

Почему в решениях 1С нет простой и удобной загрузки данных из Excel в документ? Функционал более чем востребован. Есть обработка "Загрузка данных из табличного документа", очень функциональная, но простой и удобной ее не назовешь. Предлагаю простой инструмент для загрузки данных из Excel в любой документ. Обработка реализована в виде внешней обработки заполнения объект и интегрируется в форму документа, данные загружаются в два клика из самого документа. Так же удобство обеспечивается простой и гибкой настройкой сопоставления колонок и реквизитов, для каждого реквизита табличной части настраивается из какой колонки брать значение и как его загружать, загружать как есть или это например, код номенклатуры и по нему нужно искать в справочнике.

1 стартмани

21.11.2018    9911    112    Bazil    20    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") Промо

Загрузка и выгрузка в Excel Обработка документов Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    75269    536    primat    35    

Загрузка номенклатуры (с реквизитами, свойствами, несколькими единицами измерений и их коэффициентами, объемами, весами и штрихкодами), прайсов, счетов, накладных, УПД и прочих товарных документов из Excel для Управление торговлей 10.3

Загрузка и выгрузка в Excel Оптовая торговля Ценообразование, анализ цен Прайсы Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 10 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Загружает номенклатуру, единицы измерения (вес и объем), штрихкоды (поддерживается одновременная загрузка нескольких единиц и штрихкодов), реквизиты и свойства номенклатуры, номера ГТД и серии. Загрузка производится во все документы в которых поддерживается механизм подбора номенклатуры (Заказ покупателя, Поступление товаров и услуг, Установка цен номенклатуры и многие другие). Ищет номенклатуру по наименованию, артикулу, штрихкоду и аналогичным полям в номенклатуре контрагентов. Работает в УТ 10.3 (весьма вероятно будет работать в КА 1 и УПП). Для работы необходима платформа не ниже 8.3.6. Наличие установленного Excel на компьютере не обязательно. Не загружает изображения! Не работает в БП, УТ 11, Рознице 2, УНФ и прочих новых конфигурациях!

3 стартмани

07.10.2018    19016    68    1c.pro.fun    21    

Выгрузка отчета в Excel с формулами, используя заполнение - шаблон макета для сложных формул

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Каждому программисту 1с, хоть раз, да приходилось писать выгрузку отчета из 1С в Excel с формулами. Есть много вариантов как это сделать. Но мне захотелось это сделать "по нормальному", используя как можно меньше кода выгрузки в excel, и так чтобы проще было дорабатывать. Идея была проста, все формулы засунуть в макет, и при выводе в Excel просто "проинициализировать" их. Но меня ждал облом, который мне пришлось героически преодолевать. Спойлер - в итоге все получилось...)

1 стартмани

18.07.2018    21013    55    _root    17    

Универсальное средство чтения файлов Excel Промо

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Унифицируем чтение файлов Excel, читаем "неудобные" файлы, переносим содержимое таблиц Excel через буфер обмена.

5 стартмани

27.03.2013    39442    170    Infector    4    

Приемы эффективной загрузки данных из Excel в 1С

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Показаны приемы эффективной работы с Excel для загрузки данных в 1С.

1 стартмани

13.12.2017    103873    181    alexey.kutya    103    

Вы больше не будете разбирать Excel как раньше Промо

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Кому не приходилось разбирать файлы в формате Excel? Все матерятся, плюются, требуют обещаний что "это в последний раз", но таки пишут загрузку из Excel. Потом форматы меняются, строки съезжают, колонки переставляют... Вам это не надоело?

1 стартмани

07.05.2018    40754    65    m-rv    34    

Загрузка данных из табличного документа (управляемое приложение)

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Загрузка данных из табличного документа для управляемого приложения. По функционалу схожа с типовой обработкой ИТС для обычного приложения.

1 стартмани

10.10.2017    21435    265    karpal    20    

Загрузка УПД в Бухгалтерию 3.0.111.16 из Excel Промо

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0.111.16, с заведением номенклатуры в справочник , добавлением ГТД, стран происхождения.

1 стартмани

20.10.2015    36590    37    teyana    28    

Выгрузка в XML и загрузка из XML. Пример с передачей файла с клиента на сервер и обратно

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Столкнулся с проблемой передачи файла с клиента на сервер и обратно для выгрузки и загрузки данных в XML. Много примеров для выгрузки/загрузки, но не встретил ни одного, где описывался бы механизм передачи файла на сервер и обратно

1 стартмани

03.02.2017    79272    99    Anchoret    6    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Абонемент ($m) Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    62644    8    milkers    2    

Универсальная загрузка данных в регистры сведений и справочники (+ дополнительные реквизиты) (можно через буфер из Excel)

Универсальные обработки Загрузка и выгрузка в Excel Обработка справочников Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и Управление Персоналом 2.5 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Абонемент ($m) Абонемент ($m)

Универсальная обработка для загрузки обновления данных в регистры сведений и справочники (поддерживает загрузку в дополнительные реквизиты). Открытый код. Через буфер обмена можно загрузить из EXCEL. Поддерживает загрузку по GUID.

1 стартмани

30.06.2016    41619    490    pridecom    0    

Групповая обработка номенклатуры "Крутотенюшка": выгрузка из 1С в Excel, правка и обратная загрузка в 1С с учетом изменений

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

Эта обработка очень поможет при свертках, переносах, и т.д., когда нужно провести ревизию имеющейся номенклатуры, убрать лишнее, отредактировать, изменить реквизиты, добавить свойства и загрузить все с учетом выполненных изменений в 1С.

1 стартмани

11.04.2016    30875    69    O-Planet    41    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    310353    585    Zerocl    93    

Загрузка данных из Excel Промо

Загрузка и выгрузка в Excel Обработка документов Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Загружает информацию из файлов Excel в любой документ, в шапку документа и в любую табличную часть. Сняты ограничения по количеству загружаемой информации... Теперь есть возможность сохранить настройки формы.

1 стартмани

02.04.2012    57613    1041    TSer1    80    

Программная работа с Excel из 1Сv8 - кнопки, макросы, области, отображение листов и полос прокрутки при открытии

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Буду краток, представленная информация здесь это пример работы с Excel программно из 1С, от начала - создание COMОбъект("Excel.Application"), до конца его закрытия. Тут представлен пример, как создать кнопку, присвоить ей макрос, затем добавить лист, прописать в ячейки необходимую информацию, затем установка нужного листа в момент при открытии Excel, корректное отображение листов и полосы прокрутки, затем сохранение файла в необходимый формат. Данная статья не уникальна, само собой, но в данном контексте она консолидирует информацию от различных источников и призвана только помочь в познании методов программной работы с Excel как полноценный законченный пример. Предполагается, что читатель уже имеет опыт в создании СКД отчетов.

1 стартмани

29.07.2015    23075    34    sergik_nsk    5    

Обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие

Прайсы Обработка документов Загрузка и выгрузка в Excel Ценообразование, анализ цен Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Универсальная программа для загрузки Прайс-листов в базу 1С:Предприятия 8. Основные достоинства: простота использования и широкие функциональные возможности поиска товаров для записи цен. Область применения: обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие.

10 стартмани

16.07.2015    42957    5    Destroy    2