[ШАБЛОН] Внешняя печатная форма с отладкой

Публикация № 1729824 20.09.22

Бухгалтерский учет - Печатные формы

Печать ПФ ВнешняяПФ Обработка Шаблон Печатная форма Внешняя печатная отладка

Шаблон внешней печатной формы с отладкой. Поможет быстро создавать печатные формы, необходимо лишь изменять ключевые параметры, макет и заполнение Табличного документа.

Внешняя печатная форма прикрепляется к базе как дополнительная обработка через "Дополнительные отчеты и обработки". Для отладки все выведено на форму. 

Все тесты производились на платформе 8.3.20.1914, однако код отработает на любой из 8.2, 8.3. База КА 2.4.

 

Текст модуля объекта

Функция СведенияОВнешнейОбработке() Экспорт
	
	оМетаданные = Метаданные();
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
	ПараметрыРегистрации.Наименование = оМетаданные.Синоним;
	ПараметрыРегистрации.Версия = оМетаданные.Комментарий;
	ПараметрыРегистрации.БезопасныйРежим = Ложь;
	ПараметрыРегистрации.Информация = оМетаданные.Синоним; 
		
	Назначение = Новый Массив;
	Назначение.Добавить("Документ.ЗаказКлиента");
	ПараметрыРегистрации.Вставить("Назначение", Назначение); 
	
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = оМетаданные.Синоним;
	НоваяКоманда.Идентификатор = оМетаданные.Имя;
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();

    Возврат ПараметрыРегистрации;
		
КонецФункции

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ВнешняяПечатнаяФормаСОтладкой") Тогда
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
				КоллекцияПечатныхФорм,
				"ВнешняяПФ",
				НСтр("ru='Внешняя ПФ'"),
				СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, Неопределено));
		
		ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);  
	КонецЕсли;
	
КонецПроцедуры    

Функция СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, ПараметрыПечати) Экспорт
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	ТабличныйДокумент.ОтображатьСетку = Ложь;  
	ТабличныйДокумент.ОтображатьЗаголовки = Ложь;
	ТабличныйДокумент.АвтоМасштаб = Истина;
	ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ВНЕШНЯЯ_ПФ";      
	
	Макет = ПолучитьМакет("Макет");
	
	ЭтоПервыйДокумент = Истина;
	
	УстановитьПривилегированныйРежим(Истина); 
		
	Для Каждого ЗаказКлиента Из МассивОбъектов Цикл     
				
		Если ЭтоПервыйДокумент Тогда   
			ЭтоПервыйДокумент = Ложь;
		Иначе
			ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
		КонецЕсли; 
		
		// ШАПКА
		ОбластьМакета = Макет.ПолучитьОбласть("Шапка");		
		ТабличныйДокумент.Вывести(ОбластьМакета); 
				
		// Заполнение табличного документа   
		Итого = 0; 
		Валюта = ЗаказКлиента.Валюта;
		
		// ПОДВАЛ
		ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
		
		ОбластьПодвал.Параметры.Итого = Итого;        		
		ОбластьПодвал.Параметры.ИтоговаяСтоимостьЧисло = "" + Итого + " " + Валюта;
		ОбластьПодвал.Параметры.ИтоговаяСтоимостьТекст = "(" + ЧислоПрописью(Итого, "Л=ru_RU; ДП=Истина", "рубль,рубля,рублей,м,копейка,копейки,копеек,ж,2") + ")";

		// Получение данных ответсвенных лиц из ДО по связанному документу.
		ПодписантОрганизация = "";
		ПодписантКонтрагент = "";
		ДолжностьПодписантОрганизация = "";
		ДолжностьПодписантКонтрагент = "";
		
		Результат = ИнтеграцияС1СДокументооборотВызовСервера.ДанныеОбъектаДОПоВнешнемуОбъекту(ЗаказКлиента);
		
		Если Результат <> Неопределено Тогда // найден
			Прокси = ИнтеграцияС1СДокументооборотПовтИсп.ПолучитьПрокси();   
			ОбъектXDTO = ИнтеграцияС1СДокументооборот.ПолучитьОбъект(Прокси, Результат.type, Результат.ID);
			Если ОбъектXDTO.objects.Количество() > 0 И ОбъектXDTO.objects[0].partyRows.rows.Количество() > 0 
				И ОбъектXDTO.objects[0].partyRows.rows[0].signedBy <> Неопределено Тогда
				ПодписантОрганизация = ОбъектXDTO.objects[0].partyRows.rows[0].signedBy.name;
			КонецЕсли;
			Если ОбъектXDTO.objects.Количество() > 0 И ОбъектXDTO.objects[0].partyRows.rows.Количество() > 1 
				И ОбъектXDTO.objects[0].partyRows.rows[1].signedBy <> Неопределено Тогда
				ПодписантКонтрагент = ОбъектXDTO.objects[0].partyRows.rows[1].signedBy.name;
				ФИОПодписант = СтрРазделить(ПодписантКонтрагент, " ", Истина);
				Если ФИОПодписант.Количество() = 3 Тогда
					ПодписантКонтрагент = ФИОПодписант[0] + " " + Лев(ФИОПодписант[1], 1) + ". " + Лев(ФИОПодписант[2], 1) + ".";
				КонецЕсли;
				ПодписантXDTO = ИнтеграцияС1СДокументооборот.ПолучитьОбъект(Прокси, ОбъектXDTO.objects[0].partyRows.rows[1].signedBy.objectID.type, ОбъектXDTO.objects[0].partyRows.rows[1].signedBy.objectID.ID);
				Если ПодписантXDTO.objects.Количество() > 0 Тогда
					ДолжностьПодписантКонтрагент = ПодписантXDTO.objects[0].position;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;   
		
		Если ЗначениеЗаполнено(ПодписантОрганизация) Тогда
			
			Запрос = Новый Запрос;
			Запрос.Текст = 
				"ВЫБРАТЬ
				|	ОтветственныеЛицаОрганизаций.ФизическоеЛицо КАК ФизическоеЛицо,
				|	ОтветственныеЛицаОрганизаций.Должность КАК Должность
				|ИЗ
				|	Справочник.ОтветственныеЛицаОрганизаций КАК ОтветственныеЛицаОрганизаций
				|ГДЕ
				|	ОтветственныеЛицаОрганизаций.ОтветственноеЛицо = ЗНАЧЕНИЕ(Перечисление.ОтветственныеЛицаОрганизаций.Руководитель)
				|	И ОтветственныеЛицаОрганизаций.Владелец = &Владелец
				|	И ОтветственныеЛицаОрганизаций.ДатаНачала <= &Дата
				|	И (ОтветственныеЛицаОрганизаций.ДатаОкончания >= &Дата
				|			ИЛИ ОтветственныеЛицаОрганизаций.ДатаОкончания = ДАТАВРЕМЯ(1, 1, 1))
				|	И ОтветственныеЛицаОрганизаций.ФизическоеЛицо.Наименование = &Наименование";  
			
			Запрос.УстановитьПараметр("Владелец", ЗаказКлиента.Организация);
			Запрос.УстановитьПараметр("Дата", ЗаказКлиента.Дата);
			Запрос.УстановитьПараметр("Наименование", ПодписантОрганизация); 
			
			Выборка = Запрос.Выполнить().Выбрать(); 
			Если Выборка.Следующий() Тогда
				ПодписантОрганизация = ФизическиеЛицаУТ.ФамилияИнициалыФизЛица(Выборка.ФизическоеЛицо, ЗаказКлиента.Дата);
				ДолжностьПодписантОрганизация = Выборка.Должность;
			КонецЕсли; 
			
		Иначе                                                        			
			ОтвЛ = ОтветственныеЛицаБП.ОтветственныеЛица(ЗаказКлиента.Организация, ЗаказКлиента.Дата);
			ПодписантОрганизация = ОтвЛ.РуководительПредставление;
			ДолжностьПодписантОрганизация = ОтвЛ.РуководительДолжностьПредставление;   		
		КонецЕсли;
		
		ОбластьПодвал.Параметры.Организация = ЗаказКлиента.Организация.НаименованиеСокращенное;
		ОбластьПодвал.Параметры.Контрагент = ЗаказКлиента.Контрагент.НаименованиеПолное;
		ОбластьПодвал.Параметры.ДолжностьПодписантОрганизация = ?(ЗначениеЗаполнено(ДолжностьПодписантОрганизация), ДолжностьПодписантОрганизация, "Представитель");
		ОбластьПодвал.Параметры.ДолжностьПодписантКонтрагент = ?(ЗначениеЗаполнено(ДолжностьПодписантКонтрагент), ДолжностьПодписантКонтрагент, "Представитель");
		ОбластьПодвал.Параметры.ПодписантОрганизация = ПодписантОрганизация;
		ОбластьПодвал.Параметры.ПодписантКонтрагент = ПодписантКонтрагент; 
		
		// Окрасим незаполненные поля
		Если НЕ ЗначениеЗаполнено(ДолжностьПодписантКонтрагент) Тогда
			ОбластьПодвал.Область(6,3,6,4).ЦветФона = ЦветаСтиля.ПолеСОшибкойФон;
		КонецЕсли;  
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЦикла;
	
	УстановитьПривилегированныйРежим(Ложь);
	

	Возврат ТабличныйДокумент;

КонецФункции    

 

Текст формы

&НаСервере
Функция ВыполнитьПечатьНаСервере()
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	МассивОбъектов = Новый Массив;
	МассивОбъектов.Добавить(Объект.ивЗаказ);  	
	
	ОбъектыПечати = Новый СписокЗначений;
	ОбъектыПечати.Добавить(Объект.ивЗаказ);
	
	ТабличныйДокумент = ОбработкаОбъект.СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, Неопределено);
	
	Возврат ТабличныйДокумент;	
	
КонецФункции

&НаКлиенте
Процедура ВыполнитьПечать(Команда)
	
	ВыполнитьПечатьНаСервере().Показать(); 
	
КонецПроцедуры

Данный шаблон внешней печатной формы был добавлен для ускорения поиска нужного кода и разработки.

Статья будет дорабатываться, будет добавлен полезный функционал, используемый в ПФ. 


 

Скачать файлы

Наименование Файл Версия Размер
[ШАБЛОН] Внешняя печатная форма с отладкой.:

.epf 10,86Kb
10
.epf 0.0.1 10,86Kb 10 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Отправка монитора целевых показателей деятельности пользователям

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Бесплатно (free) Бесплатно (free)

Внешняя обработка позволяет выполнять отправку Монитора целевых показателей каждому пользователю согласно его настройкам. Каждый пользователь может получить на почту свой монитор целевых показателей в формате pdf. Отправить монитор целевых показателей можно и по отдельно взятому пользователю, как пользователю, так и на выбранную почту.

13.01.2023    583    10    Neiron_1C    2    

[РАСШИРЕНИЕ] Смена стиля интерфейса. Как изменить стиль 1С из пользовательского режима. 15 вариантов оформления. Темы для 1С.

Работа с интерфейсом Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Изменение цвета стиля - актуальная задача при работе с большим количеством баз или если Вы стильный человек. Стилёвое оформление интерфейса легко настраивается из пользовательского режима и очень просто дорабатывается в конфигураторе.

23.12.2022    6307    329    Neiron_1C    47    

Интеграция СБП (SBER) и Альфа Авто

Печатные формы Оптовая торговля WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Автомобили, автосервисы Автомобили, автосервисы Россия Россия Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

В настоящее время система СБП очень часто стала использоваться в повседневной жизни. Одна из систем интеграции СБП через СБЕР. Данная конфигурация является инструментом интеграции СБП в Альфа Авто. Данная система не просто формирует статический QR, а динамический, а значит, в системе будет привязка и на покупателя, и на документ.

1 стартмани

25.10.2022    1142    5    PASAHAKA    0    

Конструктор печатных форм для ЗУП 3.1 по шаблонам MSOffice и OpenOffice Промо

Печатные формы Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m) Абонемент ($m)

Данная обработка позволяет быстро создавать печатные формы документов на основании документов из программы 1С ЗУП8 версии 3.1. Печатные формы можно заполнять на основании следующих документов: "Прием на работу", "Прием на работу списком", "Кадровый перевод", "Кадровый перевод списком", "Перемещение в другое подразделение", "Договор ГПХ" Обработка протестирована на платформе 1С:Предприятие 8.3 (8.3.12.1714) релиз ЗУП 3.1.9.187 Тонкий клиент (файловый или клиент-сервер) Установленный Microsoft office (2003 и выше) или OpenOffice/LibreOffice 09/04/2019 Исправил ошибку, возникающую, если наименование вида расчета содержит скобки.

10 стартмани

02.11.2017    37449    314    zabaluev    62    

Управление правами доступа. Просмотр прав и групп доступа на объекты. Проверить роли и профили у пользователя.

Роли и права Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка позволяет увидеть, какие роли используются для объектов, и в какие профили и группы доступа включена выбранная роль. Тестировалась на КА 2.5.8.267, ДО 2.1.31.5, БП 3.0.110.24, ЗУП 3.1.22.86, Розница 2.3.9.42, должна работать на конфигурациях с БСП.

5 стартмани

24.10.2022    1837    73    Neiron_1C    4    

Счет на оплату покупателю с QR кодом для УТ 10.3. Генерация QR-кода в УТ 10.3 на примере внешней печатной формы "Счет на оплату" для печати из Заказа клиента

Печатные формы Оптовая торговля Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

В 1С:Управление торговлей 10.3 не предусмотрена возможность для генерации QR-кода, поэтому новая возможность для оплаты не представлена. Показываю алгоритм добавления QR-кода в УТ 10.3 в виде внешней печатной формы "Счет на оплату" для печати из Заказа клиента. Делалось и тестировалось на "Управление торговлей", редакция 10.3 (10.3.57.2) / Платформа 8.3.20.1914.

1 стартмани

07.10.2022    3356    77    Neiron_1C    14    

[ШАБЛОН] Выгрузка / Загрузка данных из Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Шаблон обработки по выгрузке / загрузке данных из Excel. Обработка может быть полезна как матерым программистам, так и новичкам. Первые не будут писать код заново, а вторые получают шаблон, с которым можно начинать разбираться с выгрузкой и загрузкой из Excel. Основная задача данного шаблона - сократить время на поиск и написание кода по выгрузке / загрузке данных.

1 стартмани

19.09.2022    2176    7    Neiron_1C    0    

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) Промо

Печатные формы Пакетная печать Email рассылки Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Управление производственным предприятием 1С:Управление торговлей 10 1С:Управление торговлей 10 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    66644    55    trendy    25    

Поиск пользователей в базах через COM-Объект. Запросы в базы 1С через COM-Объект. Расширение и Обработка.

Поиск данных Инструменты администратора БД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение и обработка позволяют найти пользователя в базах, которые находятся на одном сервере. Что делать, если баз много, не открывать же все базы?)

2 стартмани

13.09.2022    1484    1    Neiron_1C    5    

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

10 стартмани

05.08.2022    6055    8    sapervodichka    4    

Печать любой печатной формы, зарегистрированной с помощью БСП, для любой конфигурации

Обработка документов Печатные формы БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Добрый день. Не так давно мне была поставлена задача сделать обработку, позволяющую для выбранного объекта конфигурации показывать список печатных форм этого объекта и выводить выбранную форму на печать. Пришлось немного поразбираться с БСП, но в итоге получилось. Работает для любой конфигурации. Одно условие только - печатная форма должна быть зарегистрирована с помощью БСП.

1 стартмани

27.07.2022    2089    4    Alex33614    2    

Мастер печатных форм v 3.3 (+English version) Промо

Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Система компоновки данных Система компоновки данных Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Создание печатных форм "с нуля" за несколько минут. Моментальная отладка. Не требует знания встроенного языка 1С. Работает в толстом, тонком и вэб-клиентах.

1 стартмани

07.03.2014    105131    1263    kser87    239    

Пример внешней печатной формы, с выводом в документ docx

Печатные формы Инструментарий разработчика Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

На основе обработки _ДемоПечатьСписанийТоваровOpenOfficeXML.epf (взята из БСП 3.1.7.110) сделал пример формирования печатной формы. Печатная форма выводится в документ с расширением docx. Шаблон документа в макете обработки.

1 стартмани

19.07.2022    1981    13    План счетов    6    

Шаблон внешней печатной формы Word

Печатные формы Инструментарий разработчика Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Шаблон внешней печатной формы в формате Word для минимизации времени разработки. Для любой конфигурации, без использования БСП.

1 стартмани

18.07.2022    1482    16    irvin12345    0    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом Промо

Печатные формы Универсальные функции Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Абонемент ($m) Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    38123    24    stvorl    1    

Обезжиривание шрифта в печатной форме (экономим тонер)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Абонемент ($m) Абонемент ($m)

Код, который убирает полужирное начертание у шрифтов в печатной форме. Тестировалось на конфигурации Бухгалтерия Предприятия 3.0.111.16. Но должно работать на любых конфигурациях с БСП.

1 стартмани

24.05.2022    2287    1    q_i    4    

Присоединение внешней печатной формы в виде файла к объекту-основанию

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В данной публикации речь пойдёт о том, как можно присоединить сформированную внешнюю печатную форму в виде файла к тому объекту (справочнику, документу и т.п.), на основании которого она была сформирована.

1 стартмани

20.05.2022    3375    1    delta    0    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме Промо

Обработка документов Печатные формы Взаиморасчеты Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    46991    5    denmax    7    

Шаблон для быстрого создания подключаемой печатной формы договоров для конфигурации Бухгалтерия 3.0. Упакован в комплект поставки для 1cfresh (пройдена проверка)

Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Абонемент ($m) Абонемент ($m)

Готовый шаблон подключаемой печатной формы для максимально быстрого создания печатной формы договоров для конфигурации Бухгалтерия 3.0. Будет полезно для программистов 1С и опытных пользователей(системных администраторов и бухгалтеров), обладающих минимальными навыками програмирования 1С. С помощью материалов из данной публикации можно максимально быстро создать и подключить к вашей базе Бухгалтерия 3.0 индивидуальную печатную форму договора, сосредоточившись на самом важном для Вас - заполнении текста самого договора. Предложенное решение предоставляет более широкие возможности по созданию печатной формы договора, чем использованием стандартного механизма встроенных шаблонов печатных форм БСП, поскольку позволяет использовать язык программирования 1С для подготовки текста Вашего документа.

2 стартмани

02.02.2022    2812    7    igor7777    6    

Печать документа из структуры подчиненности

Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

В структуру подчиненности документа добавляет кнопки "Печать", "Провести", "Распровести", "Пометить на удаление". В теории работает в любой конфигурации на управляемых формах. Расширение.

1 стартмани

07.01.2022    2922    3    dgonson    0    

Смена МОЛ в учете инвентаря на счете МЦ.04

Логистика, склад и ТМЦ Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Обработка для смены материально ответственных лиц и подразделений в учете инвентаря (хозяйственных принадлежностей) в 1С:Бухгалтерии 8.

1 стартмани

14.12.2021    3996    62    Rackhanot    12    

[x1c.ru] MXL Stamps - Печати и подписи в макетах печатных форм в несколько кликов Промо

Печатные формы Универсальные обработки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка позволяет быстро создавать поля текста из ячеек печатных форм и добавлять "под них" подписи и печати. Работает в конфигурациях на управляемых формах.

1 стартмани

22.08.2015    44370    18    GusevNA    6    

ТОРГ-12 из документа Заказ покупателя. Розница 2.3

Печатные формы Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Россия Россия Абонемент ($m) Абонемент ($m)

Расширение, использующее стандартный макет ТОРГ-12 для печати из документа "Заказ покупателя".

1 стартмани

14.12.2021    2347    2    altaro    0    

Исправление данных количества отработанных дней в печатной форме "Карточка учета исполнительного документа с оплатами"

Зарплата Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Печатная форма «Карточка учета исполнительного документа с оплатами» документа Исполнительный лист Колонка «Отработано дней» в случае увольнения сотрудника в середине месяца заполняется как за полный месяц.

2 стартмани

26.11.2021    3629    1    RizhkovSergio    0    

Печать этикеток и ценников по изменившимся ценам за период для УТ 11

Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

С помощью этого расширения вы сможете отобрать и напечатать ценники только на те товары, цены которых изменились за указанный период, или в выбранных документах установки цен.

6 стартмани

09.09.2021    3947    5    tiniji    0    

Отчет по командировке по шаблону EXCEL (ERP, УТ) с использованием дополнительных реквизитов Промо

Печатные формы Загрузка и выгрузка в Excel Учет рабочего времени Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Отчет по командировке по шаблону EXCEL – обработка генерации документа EXCEL с использованием файла шаблона. Выполнена в виде внешней печатной формы для ERP 2.0 и не требует изменения конфигурации. Содержит встроенные механизмы работы с дополнительными реквизитами документа.

2 стартмани

03.06.2015    18539    0    milkers    0    

Печать кода маркировки при приемке товаров для УТ11.4 и для Розницы 2.3

Пакетная печать Печатные формы Логистика, склад и ТМЦ Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Расширение позволяет напечатать марки из формы проверки маркируемой продукции в документе "Приобретение товаров и услуг" или "Приемка товаров ИС МП" в УТ 11 И из документа "Поступление товаров" в Рознице.

2 стартмани

01.09.2021    4392    17    tiniji    4    

"Палитра быстрой печати" ценников/этикеток товаров и создания документов поступлений для Розницы

Розничная торговля Обработка документов Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Розничная и сетевая торговля (FMCG) Розничная и сетевая торговля (FMCG) Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Предлагается расширение для конфигурации 1С:Розница, позволяющее быстро печатать ценники/этикетки товаров и создавать документы поступления через "Палитру быстрой печати" с возможностью работы из меню РМК.

10 стартмани

05.08.2021    4589    1    aximo    0    

Печать и подпись на счете. Авто отправка по электронной почте для Бухгалтерии и УТ Промо

Печатные формы Оптовая торговля Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление торговлей 10 Россия Россия Абонемент ($m) Абонемент ($m)

Подключаемая внешняя обработка позволяет формировать и отправлять счет с цветными печатью и подписями на электронную почту клиента

1 стартмани

10.04.2012    58368    1452    PiterPen    92    

Драйвер весов с печатью этикеток Масса-К

Весы Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Розница 1С:Розница Розничная и сетевая торговля (FMCG) Розничная и сетевая торговля (FMCG) Абонемент ($m) Абонемент ($m)

Обработка обслуживания весов с печатью этикеток Масса-К для УТ 10.3 и Розницы 1.0. Выгрузка осуществляется штатными средствами конфигураций.

5 стартмани

21.07.2021    4632    4    Bujum    1    

Печать этикеток и ценников из УТ 10.3 на обычные и термопринтеры Argox и Godex

Периферийные устройства Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

Удобная и быстрая печать ценников и этикеток из 1С:Управление торговлей (УТ) 10.3 на обычных принтерах и на термопринтерах Argox OS-203 DT, OS-2130D и Godex BZB2/EZ2/EZ4, Citizen CLP-521/621.

2 стартмани

12.07.2021    7135    19    w0r0n    10    

Внешняя компонента печати этикеток для 4 моделей принтеров Промо

Розничная торговля Разработка внешних компонент Периферийные устройства Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

COM-сервер (внешняя компонента) позволяет печатать этикетки на 4-е модели принтеров (+совместимые с ними по языку управления) 1) Godex EZ-2, Godex BZB-2 2) Godex EZ-2P, Godex DT-2 3) Zebra LP 2824 4) Argox OS-203DT

1 стартмани

15.08.2012    47087    109    ImageWriter    5    

Сохранение печатной формы в файл для нескольких документов с заданным именем файла

Печатные формы Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

С завидной регулярностью бухгалтерия обращается с задачей сделать им групповую обработку в разных базах по сохранению печатной формы различных документов в формате PDF и/или XLS.

1 стартмани

22.05.2021    5588    19    SerGeoSik    3    

Генератор Штрих-кода EAN 13 на основе шрифта EanGnivc.ttf Промо

Универсальные функции Розничная торговля Логистика, склад и ТМЦ Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Печать Штрих-кодов на основе Шрифта. Дает преимущества: 1) Быстрая печать - особенно заметно на принтерах штрих-кодов. 2) Идеально пропечатанный штрих-код - в отличие от печати картинок, дающих различные искажения (гребенка и т.д....). Единственный минус - регистрация шрифта))

2 стартмани

06.11.2012    59410    260    sanfoto    25    

Реализация штрих-кода ЕАН13+5 (со сроком годности)

Розничная торговля Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Розничная и сетевая торговля (FMCG) Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Реализует Штрих-Код ЕАН 13+5. Сети, типа Ленты, требуют на липках товара указывать срок годности товара, чтобы кассирша, пикая сканером покупку, не смогла продать просроченный товар. Пример реализует это.

4 стартмани

20.04.2021    4786    3    apostolis    0    

Возвращаем "нормальную" печать линейных штрихкодов в Рознице

Розничная торговля Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Абонемент ($m) Абонемент ($m)

Расширение возвращает использование старой компоненты для печати линейных штрихкодов, что улучшает их читаемость сканерами и устраняет "смазывание" при печати на некоторых принтерах.

3 стартмани

01.04.2021    4963    5    denmax    4    

Вывод кода и артикула в печатную форму документа "Заказ поставщику". 1С: УТ 11.4

Печатные формы Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 11 1С:Управление торговлей 11 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

В типовом УТ 11 в печатные формы документов (в частности, "Заказ поставщику"), можно выводить в дополнительной колонке только код или артикул номенклатуры. Но иногда возникает необходимость выводить код и артикул одновременно. Данное расширение позволяет добавить этот функционал, не затрагивая код конфигурации.

1 стартмани

01.04.2021    8089    13    Stæg    11    

Адаптация макета акта сверки из Бухгалтерии 3 Корп для сверки взаиморасчетов в Комплексной автоматизации 2.4

Печатные формы Взаиморасчеты Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Россия Россия Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Поступила задача привести внешний вид печатной формы Сверки взаиморасчетов в комплексной автоматизации 2.4 под вид акта сверки из Бухгалтерии 3. Поиски решений задачи на просторах интернета не дали своих плодов.

1 стартмани

23.03.2021    5187    5    Rabin    0    

Печать этикетки с штрихкодом и кодом маркировки для 1С:Розница 2.3

Розничная торговля Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Абонемент ($m) Абонемент ($m)

Обработка позволяет распечатать этикетки из документа Заказ на эмиссию кодов маркировки СУЗ. Выводится наименование, артикул товара, характеристика, также некоторые значения дополнительных характеристик (Цвет, Состав). Выводится ШК товара и маркировочный ШК. Размер 45*30мм.

1 стартмани

23.03.2021    4448    14    XuMbI4    0    

Сохранение и передача документов по E-mail. Счет, Акт, ТОРГ-12, Счет-Фактура 1137, Акт сверки. XLS, PDF, MXL, HTM Бухгалтерия 2.0 (КОРП) Промо

Печатные формы Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка позволяет выбирать документы за период (Счет, Реализация товаров и услуг, Счет Фактура), добавлять печати, подписи, логотип (только в счет), сохранять документы в различных форматах (XLS, PDF, MXL, HTM) и отправлять по электронной почте. Существует отбор по контрагентам.

1 стартмани

03.09.2012    25643    261    gsmirnov    13    

Печать ценников и этикеток с двумя видами цен посредством типового механизма в Рознице 2.3

Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Элементарный, легкий, типовой и дешевый способ получить этикетку с 2мя видами цен. Тестировался и разрабатывался в релизе Розница 2.3.5.32.

1 стартмани

15.02.2021    8112    108    Dmitry888    18    

Печать этикеток с кодом DataMatrix для честного знака

Розничная торговля Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Печать кода маркировки DataMatrix для этикетки из текста для честного знака. Зачастую поставщики/импортеры продукции присылают коды маркировки в файле, и требуется их повторная распечатка.

1 стартмани

11.02.2021    7272    41    anvile    15